What operating system is compatible with the HealthSpective app?

The HealthSpective app requires iOS version 9.0 or later and Android version 4.4 or later. 

Did you find this article helpful?